Results 1 to 9 of 9

Thread: Spindle won't reverse when doing a G84 tap cycle

  1. #1
    Guest Guest

    Default Spindle won't reverse when doing a G84 tap cycle

    Hello, I have a 1989 Cincinnnati Milacron Sabre 750 VMC with the acramatic 850mc controller. Anyway Has been months now and no one can figure this out. I'm stressed about it. When I do a g84 it goes through all the motions and taps but when it is supposed to reverse the spindle it just rotates slowly the same direction as it was tapping. Everything else in the cycle works like it is supposed to except the spindle rotation. Anyone out there got any ideas. I know someone in the world has had this happen besides me. I have asked numerous people and numerous forums and no one has had a clue. I have had the servo drive repaired previously to this and a new orientation card put in previous to this happening . The only thing I've had done to the machine. thanks guys. Jeremy

  2. #2
    Guest Guest

    Default

    What type of sensor is used for the spindle??Encoder, encoder with belt, sensor with gear toothe ring? I would guess it has somthing to do with one of these. Let me know which type you have to give you some more help.

  3. #3
    Guest Guest

    Default

    Hey JD,
    Thanks for replying. I just took the cover off the spindle and all I can see is a Fanuc magnetic sensor it says. There are no teeth or anything though. Just a round ring around the spindle and a sensor. I don't think I have an encoder because I was told I couldn't do rigid tapping because it doesn't have an encoder. I don't even know what to look for it it did. forgot to mention that I have been having spindle orientation problems lately too. I has to warm up for a while before it works right. Otherwise when I try to stop the spindle it just keeps spinning and then says spindle orientation error. But after I reboot the machine a few times or let it warm up for a while it works. But still won't reverse the spindle with a g84. any ideas ? thanks. Jeremy Farny

  4. #4
    Guest Guest

    Default

    Does the sensor ring look like a black smooth piece of tape? If so you probably have two sensors mounted around it some where with some guards. The cables from these sensors will go to a pre amp.(box maybe 2 X4 inches). Do not pull the sensors off or you will not be able to run the machine. Usually one of the sensors gets scratched up or the black tape looking sensor ring gets scratched and needs to be replaced. check for scratches on the ring to help give an indication of which one may be bad. Otherwise call fanuc in to check the signals from the sensors and the pre amp. They will put a scope on it. You coulc also check the cable plug endsand preamp box for coolant contamination.

  5. #5
    Guest Guest

    Default

    JD,

    My sensor ring is smooth metal and there is only sensor in the front and it does look like it has smooth black plastic or something coated on the end of it. I can see all the way around my spindle ring and there is only one sensor. I have tried everything I know and for some reason the spindle won't reverse when doing a g84. thanks. Jeremy

  6. #6
    Guest Guest

    Default

    There may be another sensor under some covers. If you are sure there is not then there may be a mark or groove cut in the sensor on top or bottom. Mark where this lines up with the housing that holds it. Try adjusting the sensor closer to the sensor ring. Usally a thin smooth business cardworks great. It should barely slide beween the sensor and ring. Many times you have to turn the spindle by had to remove the business card. If this does not work call fanuc in to check with scope and determine if it is the sensor or ring or both. Beware that if the machine still runs you may damage the ring if misadjusted. Also check on price and availability on these items. They are often not in stock.

  7. #7
    Guest Guest

    Default

    If there is no hardware problem, possibly the G84 cycle is not properly incorporated in your machine. If this is the case, and you still want to do tapping on this machine, use G01 with a "floating tap holder".

    Calculate the required feed on the basis of the chosen RPM and the lead of the thread (feed / min = RPM x lead) .

    Reverse the spindle during feed-out. M05 and a dwell (of, say, 1-2 seconds) before reversing the spindle would reduce the load on the spindle. After reversing the spindle, again specify some dwell to allow the spindle to attain the full speed before the reverse feed starts.

    The feed and RPM override should be fixed at 100%.

    It is better if the in-feed is specified as about 90-95% of the calculated feed. This would stretch the tap holder a little, and it would perform better.

    Pl note that the last few threads (in case of a blind hole) would get damaged, because the spindle rotates while the tap remains in the same position. So, make a deeper hole.

    This method should work, though I have not tried it. If you decide to give it a try, pl do send me a feedback.

  8. #8
    Guest Guest

    Default

    WILL YOUR MACHINE REVERSE AT ALL? IF YOU PROGRAM A SPEED SAY 300 RPM M04 WILL IT ROTATE CCW?

    IF IT DOES NOT IT COULD BE A PROBLEM WITH THE D/A CHIP, IT SENDS THE SPINDLE A VOLTAGE FOR THE APPROPIATE SPEED, HOWEVER IT VARIES NEGATIVE FOR ONE DIRECTION AND POSITIVE FOR THE OTHER.

    I HAD A SIMILAR PROBLEM AND THAT IS ALL THAT WAS WRONG. IT IS A CHEAP FIX ALSO.

  9. #9
    Join Date
    May 2012
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: Spindle won't reverse when doing a G84 tap cycle

    Can I see Your program sounds like a problem with your programing

Similar Threads

  1. G78-threading cycle help please
    By CHANDRU in forum Programming / Applications
    Replies: 5
    Last Post: 08-21-18, 10:16 AM
  2. g76 threading cycle (2 block g76)
    By steelman in forum Programming / Applications
    Replies: 10
    Last Post: 08-21-18, 10:03 AM
  3. Auto operation cant cycle start alarm occurs when cycle start is pushed.
    By Petro in forum General CNC & Manufacturing Discussion
    Replies: 1
    Last Post: 10-10-12, 10:28 AM
  4. AJV 25/405 tapping cycle
    By AMM2007 in forum Machine Repair & Troubleshooting
    Replies: 0
    Last Post: 07-14-11, 07:28 AM
  5. fanuc reverse index
    By carlatdmf in forum Fanuc Controls
    Replies: 2
    Last Post: 10-26-08, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •