Results 1 to 3 of 3

Thread: Da98b drive fails after random time

  1. #1
    Join Date
    Nov 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Da98b drive fails after random time

    Dear all, I recently received my CNC mill machine equipped with 3 da98b drives and controlled by a zk motion controller. Since the beginning I have a problem with the Y axis drive that works properly for a few minutes or sometime a few seconds and then it stalls. After verification I confirmed that the motion controller continue to give steps and dir impulses normally. The servo motor however start heating and make very small displacement compare to what it is supposed to do. Moreover the noise of the motor increase. Then as soon as I restart the power of the drives it comes back to normal condition for a few minutes.
    I swapped the drive wiring of X and Y axis and the problem appeared on the Y axis. It means that it concern one precise drive and not others. Finally I also distanced the power cables from the feedback cables to avoid crosstalk but it has no visible effect. Can someone help me to solve this issue?

    Regards
    Julien

  2. #2
    Join Date
    Dec 2018
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: Da98b drive fails after random time

    Quote Originally Posted by Jpasquier View Post
    Dear all, I recently received my CNC mill machine equipped with 3 da98b drives and controlled by a zk motion controller. Since the beginning I have a problem with the Y axis drive that works properly for a few minutes or sometime a few seconds and then it stalls. After verification I confirmed that the motion controller continue to give steps and dir impulses normally. The servo motor however start heating and make very small displacement compare to what it is supposed to do. Moreover the noise of the motor increase. Then as soon as I restart the power of the drives it comes back to normal condition for a few minutes.
    I swapped the drive wiring of X and Y axis and the problem appeared on the Y axis. It means that it concern one precise drive and not others. Finally I also distanced the power cables from the feedback cables to avoid crosstalk but it has no visible effect. Can someone help me to solve this issue?

    Regards
    Julien
    Hi Julien,

    Just to Clarify, then you swapped the X and Y motor, the problem did not follow the motor?
    Please provide a bit more details on the controller and your model and manufacturer purchased from.

    Regards,

  3. #3
    Join Date
    Nov 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Re: Da98b drive fails after random time

    Quote Originally Posted by YuuTool View Post
    Hi Julien,

    Just to Clarify, then you swapped the X and Y motor, the problem did not follow the motor?
    Please provide a bit more details on the controller and your model and manufacturer purchased from.

    Regards,
    dear YuuTool,

    After swapping the drivers the problem followed the driver and not the motor. After more investigation into the driver I observed that the settings were differents in the x and y driver while the one from x and z are similar. Therefore I tried to change the settings of the y driver to match the one from the x driver. It was actually not possible to do it because some of the settings range didn't allow me to match the target value. It is like if the internal firmware of the y driver was different from others.
    Finnaly I observed that if I disconnect the feedback cable of the Y drive while power is on nothing appens while the same experiment on any other driver turns it into error.
    I bought this machine somewhere called USBEART in the web it is chinese material with no brand.

    I bought a new driver because I'm pretty sure that this one has an internal failure. the new one is a very common AASD model and should arrive next week.

    best regards

Similar Threads

  1. Random tool changer issues
    By Awoz in forum Machine Repair & Troubleshooting
    Replies: 2
    Last Post: 06-11-13, 06:23 AM
  2. ?drive for Mitsubishi servo motor HA80 CS_which drive?
    By cncdubai in forum Machine Repair & Troubleshooting
    Replies: 3
    Last Post: 01-22-13, 02:33 PM
  3. GSK DA98B servo
    By AbdAttili in forum Machine Repair & Troubleshooting
    Replies: 0
    Last Post: 06-02-12, 04:15 AM
  4. fadal fails to initialize
    By nakidd in forum Machine Repair & Troubleshooting
    Replies: 1
    Last Post: 05-18-11, 01:37 PM
  5. After crash 0 return is random, not tool 1.
    By WorkingDogs in forum Machine Repair & Troubleshooting
    Replies: 3
    Last Post: 08-18-10, 07:52 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •